Deprecation of TLS 1.1

January 26, 2021

TLS 1.1 support has been deprecated.

If you have questions, please contact support@channeladvisor.com.

December 9, 2020

ChannelAdvisor will be upgrading our API standards to require Transport Layer Security (TLS) 1.2 on January 26, 2021 for security and data integrity.  On that date we will disable TLS 1.1, and any API calls made using that protocol will fail.   

Earlier this year we reached out to the developers whom we knew were using TLS 1.1, most of whom have stopped using it. While our system indicates that very few API calls are still being made with TLS 1.1, in order to ensure that all potentially affected users are notified we are reaching out to all API developers, as well as the clients who use them, to make sure that they are aware of this change and take any needed action to prevent their API calls from failing on January 26, 2021.

  • If you are certain that your API calls already use TLS 1.2 then there is no further action needed on your part. 
  • If you are unsure or want to test calling our API after making related changes on your end, use this temporary endpoint to make calls to our production system to verify that your API calls are using TLS 1.2 and will continue working after January 26:

Thank you for your help and efforts related to this important change. If you have related questions please contact support@channeladvisor.com.